Меню

Как настроить сервер по dhcp cisco packet tracer

Лабораторная работа №4: Cisco Packet Tracer (12.04.2018)

Целью лабораторной работы является изучение архитектуры и настройки локальной вычислительной сети, которая имеет в своём составе три сервера: DNS, HTTP и DHCP. Используется промежуточное сетевое устройство коммутатор.

Создание модели

1.Создать модель локальной сети, состоящей из персонального компьютера, ноутбука, принтера и двух серверов, связанных между собой коммутатором. Использовать в качестве промежуточного сетевого устройства свич, или, говоря по-русски, коммутатор. 2. Настроить работу HTTP, DNS, DHCP серверов.

Настройка модели

Настройку модели рекомендуется выполнять по следующей методике. 1.Создаем WEB-документ на сервере. 2.Настраиваем статические ip адреса серверов и DHCP на персональном компьютере, ноутбуке и принтере. Внимание: не забудьте указать адрес DNS на первом сервере.

3.Настраиваем службы DNS и HTTP первом сервере.

Пояснения: Запись типа A сообщает, что машина с именем server1.yandex.ru имеет ip-адрес 10.0.0.1. Запись типа C говорит о том, что домен www.yandex.ru хостится на машине server1.yandex.ru.

Перед выполнением лабораторной работы по видео cкачайте файл-заготовку DNS-и-HTTP-заготовка.zip . Для аутентификации на маршрутизаторах R1 и R2 используйте имя пользователя admin, для привилигированного режима пароль 123, для режима глобального конфигурирования пароль 123456.

4.Настраиваем службу DHCP на втором сервере. 5.Проверяем работу служб на персональном компьютере, ноутбуке и принтере.

Перед выполнением лабораторной работы по видео cкачайте файл-заготовку DHCP_файл-заготовка.zip . Напоминаю, что для аутентификации на маршрутизаторах R1 и R2 используйте имя пользователя admin, для привилигированного режима пароль 123, для режима глобального конфигурирования пароль 123456.

5.Настройка DHCP-сервера непосредственно на маршрутизаторе. Перед выполнением лабораторной работы по видео cкачайте файл-заготовку DHCP-на-маршрутизаторе-файл-заготовка.zip. Напоминаю, что для аутентификации на маршрутизаторах R1 и R2 используйте имя пользователя admin, для привилигированного режима пароль 123, для режима глобального конфигурирования пароль 123456.

6.Настройка серверов: FTP, Mail, DNS, HTTP, DHCP. Файл-заготовка Серверы-FTP-Mail-DNS-HTTP-DHCP-заготовка.zip . Чтобы обратиться к ftp-серверу имеющему ip-адрес 192.168.3.1 с компьютера или ноутбука, необходимо в командной строке набрать ftp 192.168.3.1

Протокол HTTP

По всем вопросам пишите в комментариях. В следующей лабораторной работе мы поговорим о wi-fi

Кол-во просмотров: 8108

Возможно, Вам будет интересно почитать:

2 комментариев(я) к “ Лабораторная работа №4: Cisco Packet Tracer ”

Отчет по выполненной работе находится по ссылке

Источник

Настройка DHCP Cisco

Протокол DHCP позволяет производить автоматическую настройку сетевых устройств. Настройка DHCP сервера на маршрутизаторе выгодна тем, что позволяет по максимум задействовать работающий маршрутизатор, повесив на него максимальное количество функционала (интернет, NAT, DHCP и т.п.). DCHP позволит маршрутизатору автоматически настраивать на клиентах следующие основные параметры:

  • IP адрес
  • Основной шлюз
  • Маска подсети
  • DNS сервера
  • Имя домена

Ниже мы приводим для вас сразу несколько разных инструкций по настройке DHCP на оборудовании Cisco.

СОДЕРЖАНИЕ:

  • Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP
  • Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer
  • Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер
  • Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети
  • Полезные команды настройке DHCP Cisco

Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP

Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer

В этой видео инструкции рассматривается процесс настройки централизованного DHCP сервера в программе Cisco Packet Tracer.

  • как настроить пулы динамических IP адресов для различных сегментов локальной сети,
  • как настроить рабочую станцию на получение динамического IP адреса,
  • как проверить наличие получения динамического IP адреса рабочей станцией.
Читайте также:  Battleblock theater как настроить геймпад

Новые команды для настройки маршрутизатора для получения пула динамических IP адресов у централизованного DHCP сервера.

Для примера рассматривается роутер R1

Настройки производятся в режиме глобальной конфигурации:

R1(config)#interface fastEthernet 0/1 — заходим в настройки интерфейса к которому подключен компьютер получающий динамический IP адрес

R1(config-if)#ip helper-address 192.168.30.11 указывается IP адрес централизованного DHCP сервера.

Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер, следующий:

R1(config)#interface Ethernet 0/1/0

R1(config-if)#ip address 172.33.56.1 255.255.255.0

R1(config)#ip dhcp excluded-address 172.33.56.1

R1(config)#ip dhcp excluded-address 172.33.56.254

R1(config)#ip dhcp pool R1SW6

R1(dhcp-config)#network 172.33.56.0 255.255.255.0

R1(config)#do sh ip prot

Routing Protocol is «bgp 1»

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

R1(config)#router bgp 1

R1(config-router)#do sh ip route

172.33.0.0/24 is subnetted, 1 subnets

C 172.33.56.0 is directly connected, Ethernet0/1/0

R1(config-router)#network 172.33.56.0 mask 255.255.255.0

Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети

Рассматривается настройка DHCP сервера на маршрутизаторе Cisco, показаны возможные причины неработоспособности сети, связанные с работой протоколов маршрутизации и варианты устранения данных неполадок.

Полезные команды настройке DHCP Cisco

  • Исключим из раздачи адрес 192.168.1.254 и адреса с 192.168.1.1 по 192.168.1.9

Router(config)# ip dhcp excluded-address 192.168.1.254

Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9

Настройка DHCP сервера включает в себя определение пула адресов, которые будут раздаваться. Для создания пула используется команда ip dhcp pool [название_пула]. После этого необходимо ввести две обязательные команды – network [адрес_сети][маска/длина_префикса] для указания сети из которой будут раздаваться адреса и default-router[адрес_default_gateway] для указания шлюза по умолчанию (можно ввести до 8 адресов).

  • команда show ip dhcp binding показывает список всех IP адресов и сопоставленных с ними MAC адресов, которые были выданы DHCP сервером.
  • команда show ip dhcp server statistics покажет статистику DHCP сервера, включая информацию об отправленных и полученных DHCP сообщениях
  • Ретрансляция DHCP (DHCP RELAY)

Команда ip helper-address [адрес_DHCP-сервера] на маршрутизаторе в режиме конфигурации интерфейса укажет ему перенаправлять broadcast сообщения от DHCP клиентов уже в виде unicast к DHCP серверу, находящемуся в другой сети.

  • Настройка роутера DHCP клиента

Иногда роутер сам должен получить IP адрес по DHCP, например от интернет-провайдера. Для этого нужно в режиме конфигурации интерфейса ввести команду ip address dhcp, после чего интерфейс будет пытаться получить адрес от DHCP сервера.

Оперативно подберем для Вас оборудование и аналоги

Источник



Как настроить сервер по dhcp cisco packet tracer

Всем привет ранее мы закончили настраивать сеть для филиалов, и разобрались со статической маршрутизацией, но все это время настраивали компьютерам ip адреса в ручную. Для решения это задачи есть служба DHCP. Можно конечно использовать Windows DHCP, при наличии лицензии на Windows Server, но Cisco тоже умеет это делать на ура. Настроим давайте DHCP службу на Cisco, рассмотрим несколько вариантов.

Принцип работы DHCP

Как работает dhcp сервер, ответ на этот вопрос очень простой. Когда компьютер появляется в локальной сети, первым делом он отсылает в сеть широковещательный запрос, по всем кто в сети. Данный пакет называется DHCPDISCOVER, в котором он спрашивает ребята есть у вас тут DHCP, если да то дай как мне ip адрес. Если HDCP сервер в локальной сети есть, то он отвечает ему пакетом DHCPOFFER, в котором говорит вот я есть, вот тебе ip адрес, будешь брать? Компьютер получив пакет DHCPOFFER, отсылаем ему ответ в виде пакета DHCPREQUEST в котором говорит, отлично я беру это ip адрес запиши его за мной, на что DHCP получив этот пакет, отвечает пакетом DHCPACK в котором говорит что записал, что это ip адрес теперь твой. Вот весь принцип.

Читайте также:  Как настроить телевизор интерсвязь мистери

В своей практике я встречал еще вот такие пакеты от dhcp сервера:

  • DHCPDECLINE — это пакет в котором клиент определил, что ip адрес, от DHCP сервера в момент предложения, уже используется кем то, и тогда будет сгенерирован новый запрос на другой ip адрес
  • DHCPRELEASE — данный пакет появляется когда клиент освобождает IP адрес
  • DHCPRENEW — Это пакет содержит в себе запрос на обновление и продление аренды ip адреса
  • DHCPINFORM — пакет, направленный клиентом к серверу DHCP, чтобы получить от него детальную информацию, пример, где находится запасной DHCP сервер в сети

Настройка dhcp cisco

Настройка для маленького офиса

У нас есть филиал, 3 компьютера, один коммутатор второго уровня Cisco 2960 и роутер Cisco 1841. Все компьютеры находятся в нативном vlan (vlan по умолчанию). Вот схема сети.

Приступаем к настройке Cisco 1841. Поднимем у него порт fa0/0 и назначим ему ip 192.168.1.1/24

Видим, что порт загорелся зеленым.

Далее создаем pool ip адресов на cisco dhcp server, для этого вводим команду: DHCP_192.168.1.0 это имя

Посмотрим теперь доступные команды

Router(dhcp-config)#?
default-router Default routers
dns-server Set name server
exit Exit from DHCP pool configuration mode
network Network number and mask
no Negate a command or set its defaults
option Raw DHCP options

Задаем в начале сеть которую будем раздавать, естественно она должна быть в том же диапазоне что и ip адрес устройства Cisco. Создаю сеть 192.168.1.0

Теперь давайте исключим из созданного пула первые 50 ip адресов, которые отдадим для серверов и про запас.

Проверка получения ip адреса

Берем первый компьютер, вводи на нем команду ipconfig чтобы посмотреть текущие настройки. Как видим, ip адрес не назначен. Так как это у меня симулятор Cisco packet tracer 6.2, то у него по умолчанию стоит статический ip в настройках, поставлю получение автоматически с DHCP.

Делаем снова ipconfig и видим, что получили ip адрес 192.168.1.51

Делаем на двух других компьютерах такие же настройки, и пробуем пропинговать друг друга, видим, все ок пинги доходят.

В малом офисе мы настроили dhcp сервер cisco.

Настройка DHCP для среднего офиса

С маленьким офисом мы разобрались, теперь рассмотрим схему среднего офиса. У нас тут уже есть сигментирование в виде vlan (2,3,4). У нас в схеме есть роутер Cisco 2911, на котором будет маршрутизация локального трафика между vlan, коммутатор второго уровня Cisco 2960 на уровне доступа конечных устройств, сервер DHCP в vlan 4, с которого мы и будем получать ip адреса.

Читайте также:  Ios 14 как настроить вибрацию

Настроим Cisco 2960

Первым делом на коммутаторе нужно создать vlan 2,3,4 и зададим им имена.

Теперь настроим порты коммутатора и добавим их в нужный vlan.

int range fa0/1-2
switchport mode access
switchport access vlan 2
exit

VLAN3 у меня порты fa0/3 и fa0/4

int range fa0/3-4
witchport mode access
switchport access vlan 3
exit

VLAN4 у меня порт fa0/5

int fa 0/5
switchport mode access
switchport access vlan 4
exit

Теперь настроим порт gi0/1 который подключается к роутеру Cisco 2911, и режим работы у него будет trunk. разрешим через trunk все 4 vlan.

Настроим Cisco 2911

Теперь приступим к настройке Cisco 2911, на нем будет маршрутизация трафика между vlan, значит для этого мы должны создать их на нем, задать им ip адреса, которые будут выступать в роли шлюзов.Вот общая схема.

первым делом мы поднимаем порт, так как на всех роутерах Cisco они в выключенном состоянии.

Проверим теперь с компьютера где ip адрес 192.168.2.1 пропинговать шлюз и соседей по vlan 3,4. Видим, что все отлично работает, связь проверена. Осталось теперь настроить DHCP сервер.

DHCP настройка

Напомню, что службой DHCP, может быть компьютер с роль на Windows Server (тут это компьютер или виртуальная машина, где есть много сетевых интерфейсов, каждый из которых подключен к нужному vlan, в который DHCP и отдает свои ip адреса), само устройство cisco, либо сторонний продукт на базе linux, вариантов много, в своей тестовой среде у меня это будет сервер в cisco packet tracer, у него есть статический ip адрес 192.168.4.1. Я создаю новый пул для VLAN2, раздавать я буду с 192.168.2.50 до 192.168.2.250, задаю шлюз по умолчанию и dns сервер.

жмем Add и добавляем наш пул. Так же создаем пул для 3 VLAN.

Теперь вспомним, что у нас DHCP сервер в другом vlan, а это значит что широковещательные запросы DHCPDISCOVER из других vlan он не видит, решить эту проблему нам поможет dhcp relay.

dhcp relay настройка

cisco dhcp relay в двух словах это ретранслятор, который отлавливает пакеты DHCPDISCOVER и перенаправляет их DHCP серверу, за счет этого можно уменьшить количество DHCP серверов. Приступим и настроим наш dhcp relay.

Теперь у нас в каждом vlan появился ретранслятор на наш dhcp сервер. Так же в целях безопасности вы можете настроить, чтобы у вас доверенным был только определенный dhcp сервер с определенного порта, а все остальные будут игнорироваться. Возьмем за тест компьютер со статическим ip 192.168.2.1, посмотрим текущие настройки сети командой ipconfig, ставим автоматическое получение, и видим что получили 192.168.2.50. DHCP в vlan2 работает.

Полезные команды cisco dhcp

Смотрим статистику по пакетам и привязкам

Смотрим кому какой ip адрес присвоен

Вот так вот работает и настраивается DHCP и DHCP Relay в сети. Надеюсь было позновательно.

Источник